Results 1 to 4 of 4

Thread: 617HP all boost 4.8L..now running 75 dry shot

  1. #1
    Potential Tuner
    Join Date
    Feb 2010
    Posts
    9

    617HP all boost 4.8L..now running 75 dry shot

    Hey guys, I was wondering if someone could look at this log and tell me why it's spraying past my 5950rpm cutoff. It seems to keep spraying on and off at 6300.

    Setup:

    Stock 4.8L w/ls6 cam/springs
    MP70 @ 15psi makes 617HP/623TQ
    Dual Walbro, 80LB injectors, E85

    After the dyno tune, I've added a 35, then 50, now 75HP shot. Currently on the .42 pill, 950psi bottle pressure, 15psi boost.

    Current Disable trigger:
    [SENS.90] < 98 OR [PID.12] > 5950 OR [SENS.120] > 12.3

    Also, always read rev limit and nitrous = bad news. Is this true with a dry shot or is that mostly for the wet camp?
    Thanks guys
    Attached Files Attached Files
    Last edited by Foose04; 07-24-2010 at 02:15 AM.

  2. #2
    Potential Tuner
    Join Date
    Feb 2010
    Posts
    9

    2004 GMC RST: 4.8L/Turbo/E85: 617HP/623TQ
    http://www.youtube.com/watch?v=V9nRm6vZl_I
    91 Eagle Talon 2.0L/Turbo/E85-10.61@136, 570AWHP Mustang Dyno
    http://www.youtube.com/watch?v=yB9kDxXRLgw

  3. #3
    Senior Tuner
    Join Date
    Feb 2007
    Location
    San Antonio, TX
    Posts
    1,257
    Quote Originally Posted by Foose04 View Post
    Also, always read rev limit and nitrous = bad news. Is this true with a dry shot or is that mostly for the wet camp?
    Thanks guys
    Statement is 100% accurate. Hit fuel cutoff (rev limit) and nitrous doesn't cut prior you're gonna go lean. Your taking away the fuel in the fuel/oxygen equation at that point. Not good with boost on top of it. Have you considered running a seperate window switch?

    Have you tuned your MAF/VE tables? Your STFT/LTFT are way outa' whack...You're running your injectors at 99%+ duty cycle. They need to be replaced (upgraded!).
    Last edited by Cantalope Kid; 07-24-2010 at 11:45 AM.
    Janky Monkey Tuning

    Call or PM for tuning solutions.

    Cell 210-954-4985

    Wrench turning provided by 2 Tightwads Racing.

    Tune your own? Start here ----> Open Editor ---> Hit F1...READ!

    READ SOME MORE (Thank username 69Lt1bird): http://ls1tuningguide.com/

    Still lost? Consult a Pro!

    www.thetuningschool.com
    www.calibratedsuccess.com
    www.tunedbyfrost.com

  4. #4
    Advanced Tuner ElecTech's Avatar
    Join Date
    Feb 2006
    Location
    Charleston, SC
    Posts
    595
    Quote Originally Posted by Foose04 View Post
    Hey guys, I was wondering if someone could look at this log and tell me why it's spraying past my 5950rpm cutoff. It seems to keep spraying on and off at 6300.
    It may just be a lag in the display response. Your output may be responding on time but the "log" is behind slightly.

    If you drag the maker from the left to right it shows it on until 6300, but if you then drag it back from right to left it stays off at RPM=6184. Still an overshoot, but I'm not sure I completely trust what I'm seeing. I would try to find another way to verify the display.

    Also, I would definately take the rev limiter way out of range running a dry until you get a reliable window worked out.


    EDIT: After a little reading, your output disable relies on that statement to be true for at least 1 frame before it switches. You may need to adjust your statement quals to get the desired switchpoint.
    Last edited by ElecTech; 07-26-2010 at 10:34 AM.
    Jaime